ClosestPointsPairBetweenTwoCurves Class


Closest Points Pair Between Two Curves Class

This class captures results of computation of closest points between two generic curves.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ClosestPointsPairBetweenTwoCurves

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ClosestPointsPairBetweenTwoCurves : IDisposable

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Constructors
Name Description
Public method ClosestPointsPairBetweenTwoCurves Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.
Public method ClosestPointsPairBetweenTwoCurves(ClosestPointsPairBetweenTwoCurves) Creates a copy of the ClosestPointsPairBetweenTwoCurves.
Top
Properties
Name Description
Public property Distance Distance from point on first curve to the point on second curve.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ParameterOnFirstCurve 1d raw (not normalized) parameter of the point on the first curve.
Public property ParameterOnSecondCurve 1d raw (not normalized) parameter of the point on the second curve.
Public property XYZPointOnFirstCurve Point on the first curve in 3d coordinates.
Public property XYZPointOnSecondCurve Point on the second curve in 3d coordinates.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ClosestPointsPairBetweenTwoCurves
Top
See Also