Assembly |
Places an assembly instance of a given assembly type at the specified location.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static AssemblyInstance PlaceInstance(
Document document,
ElementId assemblyTypeId,
XYZ location
)
Parameters
- document Document
- The document for the new assembly instance.
- assemblyTypeId ElementId
- The id of the assembly type to be used for the instance.
- location XYZ
- The placement location for the instance in project coordinates.
Return Value
AssemblyInstanceThe newly created assembly instance.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |