ElementLogicalFilter Class


Element Logical Filter Class

A filter used to logically combine two or more filters.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementLogicalFilter : ElementFilter

The ElementLogicalFilter type exposes the following members.

Properties
Name Description
Public property Inverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter )
Top
Methods
Name Description
Public method Dispose
(Inherited from ElementFilter )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetFilters Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method PassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method SetFilters
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also