ElementLogicalFilter Class


Element Logical Filter Class

A filter used to logically combine two or more filters.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementLogicalFilter : ElementFilter

The ElementLogicalFilter type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method GetFilters Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.
Public method SetFilters
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also