Performance |
The unique identifier of a PerformanceAdviserRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PerformanceAdviserRuleId type exposes the following members.

Name | Description | |
---|---|---|
![]() | PerformanceAdviserRuleId | Creates a new PerformanceAdviserRuleId instance. |


Name | Description | |
---|---|---|
![]() | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum ) |
![]() | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Name | Description | |
---|---|---|
![]() ![]() | Equality(PerformanceAdviserRuleId, PerformanceAdviserRuleId) | Compares two PerformanceAdviserRuleId instances. |
![]() ![]() | Inequality(PerformanceAdviserRuleId, PerformanceAdviserRuleId) | Compares two PerformanceAdviserRuleId instances. |

Each performance adviser rule registered in application must be given a unique id that can be used to identify and unregister rule later.