Curve |
Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- arr ReferencePointArray
- An array of ReferencePoints. The array is reordered if sortPoints returns true, and is unchanged if sortPoints returns false.
Return Value
BooleanFalse if the least-squares method is unable to find a solution; true otherwise.

Finds a best-fit line to the points by the least squares method, and orders the points by their projection onto the line.