AsElementId Method


Parameter As Element Id Method

Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId AsElementId()

Return Value

ElementId
The Autodesk::Revit::DB::ElementId^ contained in the parameter.
Remarks
The AsAutodesk::Revit::DB::ElementId^ method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.
See Also