LogicalAndFilter Class


Logical And Filter Class

A filter that contains a set of filters. The filter passes when all filters in the set pass.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LogicalAndFilter : ElementLogicalFilter

The LogicalAndFilter type exposes the following members.

Constructors
Name Description
Public method LogicalAndFilter(IList ElementFilter ) Initializes a new instance of the LogicalAndFilter class
Public method LogicalAndFilter(ElementFilter, ElementFilter) Constructs a new instance of the logical filter with two input filters.
Top
Properties
Name Description
Top
Methods
Name Description
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also