Multi |
If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool AreReferencesValidForLinearDimension(
Document document,
ElementId ownerViewId,
MultiReferenceAnnotationOptions options
)
Parameters
- document Document
- The document for the multi-reference annotation.
- ownerViewId ElementId
- The view in which the multi-reference annotation will appear.
- options MultiReferenceAnnotationOptions
- Options containing the references which the dimension will witness.
Return Value
BooleanTrue DimensionStyleType does not equal Linear or if an aligned multi-reference annotation can be created from the references.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |