ExternalResourceTypes.BuiltInExternalResourceTypes Class


External Resource Types Built In External Resource Types Class

A collection of ids of the ExternalResourceTypes provided by Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceTypes BuiltInExternalResourceTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class BuiltInExternalResourceTypes

The ExternalResourceTypes BuiltInExternalResourceTypes type exposes the following members.

Properties
Name Description
Public property Static member AssemblyCodeTable An external resource type representing assembly code data.
Public property Static member CADLink An external resource type representing CAD Links data.
Public property Static member DecalBumpMap An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.
Public property Static member DecalCutOut An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.
Public property Static member DecalImage An external resource type representing decal images.
Public property Static member DecalMap An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.
Public property Static member DWFMarkup An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.
Public property Static member FabricationConfiguration An external resource type representing an MEP fabrication configuration.
Public property Static member IFCLink An external resource type representing IFC links.
Public property Static member Image An external resource type representing images.
Public property Static member KeynoteTable An external resource type representing keynote data.
Public property Static member MaterialTexture An external resource type representing material texture images.
Public property Static member PointCloud An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.
Public property Static member RevitLink An external resource type representing Revit Links data.
Public property Static member SystemsAnalysisReport An external resource type representing systems analysis report path.
Public property Static member TopographyLink An external resource type representing Topography Links.
Top
See Also