RevitLinkOptions Class


Revit Link Options Class

This class contains the options in use when creating or loading a Revit link.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RevitLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitLinkOptions : IDisposable

The RevitLinkOptions type exposes the following members.

Constructors
Name Description
Public method RevitLinkOptions(Boolean) Creates a RevitLinkOptions object, specifying relative or absolute path type. If the link is workshared, all worksets will be opened.
Public method RevitLinkOptions(RevitLinkOptions) Constructs a new copy of the input RevitLinkOptions object.
Public method RevitLinkOptions(Boolean, WorksetConfiguration) Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.
Top
Properties
Name Description
Public property IsRelative The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RevitLinkOptions
Public method Code example GetWorksetConfiguration Gets the set of worksets to open when creating the link.
Public method SetWorksetConfiguration Sets the set of worksets to open when creating the link.
Top
See Also