ElementIntersectsElementFilter Class


Element Intersects Element Filter Class

A filter to find elements that intersect the solid geometry of a given element.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementIntersectsElementFilter : ElementIntersectsFilter

The ElementIntersectsElementFilter type exposes the following members.

Constructors
Name Description
Public method ElementIntersectsElementFilter(Element) Constructs a filter to match elements which intersect the given element.
Public method ElementIntersectsElementFilter(Element, Boolean) Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.
Top
Properties
Name Description
Top
Methods
Name Description
Public method GetElement Gets the target element.
Top
Remarks

The target object is another element. The intersection is determined with the same logic used by Revit to determine if an interference exists during generation of an Interference Report. (This means that some combinations of elements will never be detected as intersecting by this filter, such as concrete members which are automatically joined at their intersections). Also, elements which have no solid geometry, such as Rebar, will never be detected as intersecting by this filter.

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

See Also