NewCurveByPoints Method


Family Item Factory New Curve By Points Method

Create a 3d curve through two or more points in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public CurveByPoints NewCurveByPoints(
	ReferencePointArray points
)

Parameters

points ReferencePointArray
Two or more PointElements. The curve will interpolate these points.

Return Value

CurveByPoints
The newly created curve.
Exceptions
Exception Condition
ArgumentNullException Thrown when points is .
ArgumentException Thrown when points does not contain at least two PointElements.
InvalidOperationException Thrown when the family is not a Conceptual Mass Family.
See Also