PickObject Method (ObjectType, String)


Selection Pick Object(Object Type, String) Method

Prompts the user to select one object while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Reference PickObject(
	ObjectType objectType,
	string statusPrompt
)

Parameters

objectType ObjectType
Specifies the type of object to be selected.
statusPrompt String
The message shown on the status bar.

Return Value

Reference

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Exceptions
Exception Condition
ArgumentOutOfRangeException Thrown when the objectType is not a recognized value.
ArgumentNullException Thrown when the statusPrompt is .
OperationCanceledException Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
ForbiddenForDynamicUpdateException Thrown if this method is called during dynamic update.
Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

See Also