Multistory |
Restores an unpinned stairs element back into the group of stairs governed by level height.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- levelId ElementId
- The base level id. If the level id belongs to the base level of an individual pinned stairs, it returns the stairs id directly.
Return Value
StairsThe stairs element which the pinned story belongs to.

Exception | Condition |
---|---|
ArgumentException | There is no stairs instance at the given base levelId. |
ArgumentNullException | A non-optional argument was null |

If the level height of current story can be found among other stories, the stair will be added back into the group; Otherwise only the status will be changed to "pinned".