Dialog |
An object that is passed to your application when a dialog is displayed in Revit.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.UI.Events DialogBoxData
Autodesk.Revit.UI.Events MessageBoxData
Autodesk.Revit.DB APIObject
Autodesk.Revit.UI.Events DialogBoxData
Autodesk.Revit.UI.Events MessageBoxData
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The DialogBoxData type exposes the following members.

Name | Description | |
---|---|---|
![]() | HelpId | An ID that represents the dialog that has been displayed. |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.