Plane Create |
Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- origin XYZ
- Plane origin. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ) .
- basisX XYZ
- First of the two unit vectors that define the plane. Must be orthogonal to the second one.
- basisY XYZ
- Second of the two unit vectors that define the plane. Must be orthogonal to the first one.
Return Value
Plane
Exception | Condition |
---|---|
ArgumentException | The input point lies outside of Revit design limits. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | basisX is not length 1.0. -or- basisY is not length 1.0. |
ArgumentsInconsistentException | The vectors basisX and basisY are not perpendicular. |

The parametric equation of the plane is S(u, v) = origin + u*basisX + v*basisY. The plane's normal is defined as basisX.Cross(basisY).