Document New |
Creates a new space element on the given level at the given location.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- level Level
- The level on which the space is to exist.
- point UV
- A 2D point that dictates the location on that specified level.
Return Value
SpaceIf successful the new space element is returned, otherwise .

Exception | Condition |
---|---|
ArgumentNullException | Thrown when level or point is . |
InvalidOperationException | Thrown when the space cannot be created. |
ArgumentException | Thrown if the level does not exist in the given document. |