HomeCamera Class


Home Camera Class

A structure that contains information about the camera and view for the Home view orientation stored in the model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB HomeCamera

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HomeCamera : IDisposable

The HomeCamera type exposes the following members.

Constructors
Name Description
Public method HomeCamera Constructs a new copy of the input HomeCamera object.
Top
Properties
Name Description
Public property BottomAngleOfFieldOfView The bottom angle of the field of view.
Public property Center The zoom or orbit center.
Public property EyePosition The eye position point.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LeftAngleOfFieldOfView The left angle of the field of view.
Public property OrthogonalProjectionHeight The height of orthogonal projection view volume.
Public property OrthogonalProjectionWidth The width of orthogonal projection view volume.
Public property Pivot The pivot point.
Public property RightAngleOfFieldOfView The right angle of the field of view.
Public property TopAngleOfFieldOfView The top angle of the field of view.
Public property UpDirection The up direction vector.
Public property ViewId The id of the view which is associated to this document's Home view orientation.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the HomeCamera
Top
See Also