Direct |
Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- refPlane Plane
- The geometry of the new reference plane.
- options DirectShapeReferenceOptions
- The options that are used to configure the new reference plane.

Exception | Condition |
---|---|
ArgumentException | options cannot be used to add a reference object to this DirectShape. |
ArgumentNullException | A non-optional argument was null |