CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)


Analysis Display Style Create Analysis Display Style(Document, String, Analysis Display Deformed Shape Settings, Analysis Display Color Settings, Analysis Display Legend Settings) Method

Factory method - creates analysis display style object of type Deformed Shape for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
	Document document,
	string name,
	AnalysisDisplayDeformedShapeSettings deformedShapeSettings,
	AnalysisDisplayColorSettings colorSettings,
	AnalysisDisplayLegendSettings legendSettings
)

Parameters

document Document
Document for which analysis display style object is created.
name String
Name of the analysis display style within the %document%.
deformedShapeSettings AnalysisDisplayDeformedShapeSettings
Deformed Shape settings for the style.
colorSettings AnalysisDisplayColorSettings
Color settings for the style.
legendSettings AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

AnalysisDisplayStyle
New analysis display style object.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException document is a family. -or- name is not unique in document.
See Also