StructuralWallUsageFilter Class


Structural Wall Usage Filter Class

A filter used to match walls that have the given structural wall usage.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralWallUsageFilter : ElementSlowFilter

The StructuralWallUsageFilter type exposes the following members.

Constructors
Name Description
Public method StructuralWallUsageFilter(StructuralWallUsage) Constructs a new instance of a filter to match walls that have the given structural wall usage.
Public method StructuralWallUsageFilter(StructuralWallUsage, Boolean) Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.
Top
Properties
Name Description
Public property StructuralWallUsage The wall structural usage.
Top
Methods
Name Description
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
See Also