SetFilter Method


Schedule Definition Set Filter Method

Replaces a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFilter(
	int index,
	ScheduleFilter filter
)

Parameters

index Int32
The index of the filter to replace.
filter ScheduleFilter
The new filter.
Exceptions
Exception Condition
ArgumentException The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException index is not a valid filter index.
InvalidOperationException This ScheduleDefinition does not support filters.
See Also