GetProjectPosition Method


Project Location Get Project Position Method

Gets the coordinates of a point in the ProjectLocation's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ProjectPosition GetProjectPosition(
	XYZ point
)

Parameters

point XYZ

Return Value

ProjectPosition
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Unable to use the project position's transform to calculate the point.
Remarks

When getting this value, the North/South, East/West, and Elevation values report the coordinates of the point similar to the Revit command "Report Shared Coordinates". To get the values of the transformations applied by this project location, pass XYZ.Zero.

If the project has acquired shared coordinates from a linked model, the shared coordinate transformation will be reflected in the coordinates of the transformed point returned by this property.

See Also