Asset |
Represents a set of asset property(s).

System Object
Autodesk.Revit.DB.Visual AssetProperty
Autodesk.Revit.DB.Visual AssetProperties
Autodesk.Revit.DB.Visual Asset
Autodesk.Revit.DB.Visual AssetProperty
Autodesk.Revit.DB.Visual AssetProperties
Autodesk.Revit.DB.Visual Asset
Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AssetProperties type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. If true, the object may not be modified. If false, the object's contents may be modified. (Inherited from AssetProperty ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssetProperty ) |
![]() | Item | |
![]() | Name | Get the name of the AssetProperty (Inherited from AssetProperty ) |
![]() | NumberOfConnectedProperties | The number of currently connected properties. (Inherited from AssetProperty ) |
![]() | Size | The number of the AssetProperty(s) in the object. |
![]() | Type | Returns the type of the AssetProperty (Inherited from AssetProperty ) |

Name | Description | |
---|---|---|
![]() | AddConnectedAsset | Adds a new connected asset attached to this asset property, if it allows it. (Inherited from AssetProperty ) |
![]() ![]() | AddCopyAsConnectedAsset | Makes a copy of the asset and connects it to this property. (Inherited from AssetProperty ) |
![]() | Dispose | (Inherited from AssetProperty ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | FindByName | Gets the property with the given name. |
![]() | Get | Gets the property at the given index. |
![]() | GetAllConnectedProperties | Gets the list of the connected properties. Connected properties are the detachable properties of an AssetProperty. e.g. diffuse property can have texture as its connected property. It can also detach texture on runtime. (Inherited from AssetProperty ) |
![]() | GetConnectedProperty | Gets one connected property with specified index. (Inherited from AssetProperty ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() ![]() | GetSingleConnectedAsset | Gets the single connected asset attached to this asset property, if it exists. (Inherited from AssetProperty ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsEditable | Check if property can be edited. (Inherited from AssetProperty ) |
![]() | IsValidIndex | Returns true if the provided index is valid. |
![]() | IsValidSchemaIdentifier | Check that schema name is valid (Inherited from AssetProperty ) |
![]() | RemoveConnectedAsset | Removes the connected asset attached to this asset property if any. (Inherited from AssetProperty ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |