Asset |
Represents a set of asset property(s).

System Object
Autodesk.Revit.DB.Visual AssetProperty
Autodesk.Revit.DB.Visual AssetProperties
Autodesk.Revit.DB.Visual Asset
Autodesk.Revit.DB.Visual AssetProperty
Autodesk.Revit.DB.Visual AssetProperties
Autodesk.Revit.DB.Visual Asset
Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AssetProperties type exposes the following members.

Name | Description | |
---|---|---|
![]() | Item | |
![]() | Size | The number of the AssetProperty(s) in the object. |

Name | Description | |
---|---|---|
![]() | FindByName | Gets the property with the given name. |
![]() | Get | Gets the property at the given index. |
![]() | IsValidIndex | Returns true if the provided index is valid. |