Is3DViewValidForDimension Method


Multi Reference Annotation Is 3DView Valid For Dimension Method

If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool Is3DViewValidForDimension(
	Document document,
	ElementId ownerViewId,
	MultiReferenceAnnotationOptions options
)

Parameters

document Document
The document for the multi-reference annotation.
ownerViewId ElementId
The view in which the multi-reference annotation will appear.
options MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.

Return Value

Boolean
True if the view is suitable for placing the MultiReferenceAnnotation. False otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also