DataConversionMonitorScope Class


Data Conversion Monitor Scope Class

This class is used to regsiter an application-supplied object that implements IDataConversionMonitor. Creating the object registers an implementation of IDataConversionMonitor supplied as constructor argument. When the scope object is destroyed, that object is unregistered.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DataConversionMonitorScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DataConversionMonitorScope : IDisposable

The DataConversionMonitorScope type exposes the following members.

Constructors
Name Description
Public method DataConversionMonitorScope The only constructor. Expects a valid pointer to IDataConversionMonitor.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DataConversionMonitorScope
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also