ComputeSubcomponents Method


Exporter IFCUtils Compute Subcomponents Method

Splits a roof or floor element composed of planar surfaces into a set of roughly vertical extruded loops of uniform depth if possible.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<HostObjectSubcomponentInfo> ComputeSubcomponents(
	HostObject roofOrFloor
)

Parameters

roofOrFloor HostObject
The roof or floor.

Return Value

IList HostObjectSubcomponentInfo
A collection of computed components.
Exceptions
Exception Condition
ArgumentException The host object roofOrFloor must be a floor or a non face-based roof.
ArgumentNullException A non-optional argument was null
InvalidOperationException The roof or floor cannot be split into subcomponents by this routine. Possible reasons are, among others: (1) the roof or floor contains non-planar surfaces, (2) the roof or floor cannot be divided into sub-components of equal thickness, or (3) the roof subcomponents contain inner boundary loops.
See Also