StairsEditScope Class


Stairs Edit Scope Class

StairsEditScope allows user to maintain a stairs-editing session.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB EditScope
Autodesk.Revit.DB StairsEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class StairsEditScope : EditScope

The StairsEditScope type exposes the following members.

Constructors
Name Description
Public method StairsEditScope Instantiates a StairsEditScope object.
Top
Properties
Name Description
Public property IsActive Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
(Inherited from EditScope )
Public property IsPermitted Tells if the edit scope is permitted to start.
(Inherited from EditScope )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from EditScope )
Top
Methods
Name Description
Public method Cancel Cancels the edit scope.
(Inherited from EditScope )
Public method Commit Finishes the edit scope.
(Inherited from EditScope )
Public method Dispose
(Inherited from EditScope )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Start(ElementId) Starts an stairs edit mode for an existing Stairs element
Public method Start(ElementId, ElementId) Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Start/end of a StairsEditScope will start/end a transaction group. After a StairsEditScope is started, user can start transactions and edit the stairs. Individual transactions the user creates inside StairsEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into StairsEditScope constructor.
See Also