StairsEditScope Class


Stairs Edit Scope Class

StairsEditScope allows user to maintain a stairs-editing session.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB EditScope
Autodesk.Revit.DB StairsEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class StairsEditScope : EditScope

The StairsEditScope type exposes the following members.

Constructors
Name Description
Public method StairsEditScope Instantiates a StairsEditScope object.
Top
Properties
Name Description
Top
Methods
Name Description
Public method Start(ElementId) Starts an stairs edit mode for an existing Stairs element
Public method Start(ElementId, ElementId) Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Top
Remarks
Start/end of a StairsEditScope will start/end a transaction group. After a StairsEditScope is started, user can start transactions and edit the stairs. Individual transactions the user creates inside StairsEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into StairsEditScope constructor.
See Also