UIMacro |
Adds a MacroModule to the application.
Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUIMacros (in RevitAPIUIMacros.dll) Version: 25.0.0.0 (25.0.0.0)

public MacroModule AddModule(
ModuleSettings moduleSettings,
MacroEnvironment environment,
IModuleMaker maker
)
Parameters
- moduleSettings ModuleSettings
- The module settings.
- environment MacroEnvironment
- The module environment.
- maker IModuleMaker
- The interface to create module project.
Return Value
MacroModuleThe new module.

Exception | Condition |
---|---|
ArgumentException | Thrown when the module name is duplicated with the existing one, or the name is too long, or the name contains invalid identifier(s), such as include "#", "%", ... and key words in C#. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |