ViewFilterType Property


Revit Link Graphics Settings View Filter Type Property

The view filter type of RevitLinkGraphicsSettings. If the LinkVisibilityType is set to ByHostView , then the view filter type should be set to ByHostView . If the LinkVisibilityType is set to ByLinkView , then the view filter type should be set to ByLinkView . If the LinkVisibilityType is set to Custom , then the view filter type can be set to any value from LinkVisibility enum. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView . The Custom value corresponds to None option in the UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LinkVisibility ViewFilterType { get; set; }

Property Value

LinkVisibility
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also