BasicLossFactor Class


Basic Loss Factor Class

This class encapsulates basic lighting loss factor calculation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LossFactor
Autodesk.Revit.DB.Lighting BasicLossFactor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BasicLossFactor : LossFactor

The BasicLossFactor type exposes the following members.

Constructors
Name Description
Public method BasicLossFactor Creates a basic loss factor object with no loss.
Public method BasicLossFactor(BasicLossFactor) Creates a copy of the given basic loss factor object
Public method BasicLossFactor(Double) Creates a basic loss factor object with the given value.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from LossFactor )
Public property LossFactor The loss factor.
Public property LossFactorValue The calculated loss factor value
(Inherited from LossFactor )
Top
Methods
Name Description
Public method Clone Creates a copy of the LossFactor derived object.
(Inherited from LossFactor )
Public method Dispose
(Inherited from LossFactor )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also