BuiltInFailures.FamilyFailures Class


Built In Failures Family Failures Class

Failures related to families.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures FamilyFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static class FamilyFailures

The BuiltInFailures FamilyFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotAddParameterToFamily Parameter '[Parameter]' cannot be added to the family.
Public property Static member CannotApplySplitWithGap Can't make structural element.
Public property Static member CannotChangeCategory Can't change category of Family Instance
Public property Static member CannotChangeInstFam Can't change Instance's Family. Try changing Instance's Host to a Level first.
Public property Static member CannotChangeTypeLineBased Can't change type of "[Family Name]" from line based to non-line based or vice-versa.
Public property Static member CannotConvertInstHostToWorkPlane Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
Public property Static member CannotConvertInstWorkPlaneToHost Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
Public property Static member CannotCopyByPatternFamilies Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
Public property Static member CannotCopyInplaceFamily In-place family groups cannot be copied between in-place families of the same project.
Public property Static member CannotCopyWatchCurveBasedFixture
Public property Static member CannotCutRefPlane Can't cut reference plane.
Public property Static member CannotFindHost Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
Public property Static member CannotLoadImperialFamilyToMetricProject Can't load an imperial Family into a metric Project.
Public property Static member CannotLoadMetricFamilyToImperialProject Can't load a metric Family into an imperial Project.
Public property Static member CannotMakeType
Public property Static member CannotMakeTypeCB Can't make type "[Family Name]".
Public property Static member CannotMakeTypeFamilySaved Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
Public property Static member CannotPasteLabelsAcrossFamilies Can't paste Labels across Families of different Categories.
Public property Static member CannotPasteObject Can't paste some or all of the selected objects.
Public property Static member CannotRegenerateCorruptFamily Family [Family Name] is corrupt and its instances cannot be updated. Please reload the family to repair the project..
Public property Static member CannotRotateElement Can't rotate element into this position.
Public property Static member CannotSetFamilyTypeToNone Cannot set Family Type to 'None';.
Public property Static member CannotSplitElement Can't split structural element
Public property Static member CannotSplitWhileBackgroundTasksAreInProgress Cannot split element while background tasks are in progress.
Public property Static member CannotUnlockFamilyTemplate Can't unlock alignments from Family Template.
Public property Static member CantCopySelectionToNonStory Can't copy this selection to a non-story Level.
Public property Static member CantEditWhileGrouped You may not edit this parameter while the element is grouped.
Public property Static member CantMirrorInstWoHost Can't mirror an instance without its host.
Public property Static member CantMoveFrozenInstance A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
Public property Static member CantPasteSelection Can't paste selection.
Public property Static member CantPlaceATOnDuctError The air terminal cannot be placed in an elevation or section view unless it is attached to a duct.
Public property Static member CantPlaceInsertsError Can't place inserts outside of hosts. These elements won't be copied.
Public property Static member CantPlaceInsertsWarning Can't place inserts outside of hosts. These elements won't be copied.
Public property Static member CantPlaceInstanceError Can't place instance of [Symbol]
Public property Static member CantPlaceInstanceWarning Can't place instance of [Symbol]
Public property Static member CantSetSlantedColumnEndPlane Unable to determine slanted column end cut plane.
Public property Static member CantSolve Can't find solution for formulas for Type '[Type Name]'.
Public property Static member CircularRefsForInstParams "Instance parameter '%1!s!' generates circular references."
Public property Static member ColumnAlreadyAttachedWillBeReattached The column is already attached. It will be detached and attached to the new target.
Public property Static member ColumnAndTargetAlreadyJoined The column and target are joined, remove that join before attaching them.
Public property Static member ColumnHeightZeroBecauseOfInvalidOffset Change Offset Value so that Column height is not 0.0.
Public property Static member ColumnTooLong This column is too long. Maximum length is 30,000 ft.
Public property Static member ContainsSharedSameNameFamily Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
Public property Static member CouldNotGenerateReferencesForFamilyInstance Could not generate references for Family Instance.
Public property Static member CouldNotPlaceAdaptiveFamInst Could not place Adaptive Family Instance.
Public property Static member CustomFittingCreated Custom fitting was created.
Public property Static member DeletingBadFamElemCorruption Family contains invalid elements. They will be deleted.
Public property Static member DeletingBadFamElemError Family contains invalid elements. They will be deleted.
Public property Static member DeletingBadFamType Can't make type "[Family Name]". It will be deleted.
Public property Static member DeletingBadFamTypeDumped Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
Public property Static member DummyHostMustBePerpendicularToXY Dummy host must be perpendicular to Z or Y axis.
Public property Static member DuplicateFamilyParameterNameWithSharedParameter Parameter '[Parameter]' has the same name with an existing shared parameter.
Public property Static member DuplicateParamName Family parameters have duplicate names.
Public property Static member DuplicateTypeName "Ignoring attempt to add family type '%1!s!' for a second time."
Public property Static member ElementTypeParameterized The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
Public property Static member FailedToBecomeNonParametric Family failed to become non-parametric!
Public property Static member FailedToSetParameters Failed to apply family parameters.
Public property Static member FailedWhenLoadingFamily Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
Public property Static member FamilyBadUnattachedVoids Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.
Public property Static member FamilyCannotBeUpgraded "Family '[Name]' cannot be upgraded and must be deleted. To fix the file in the older version of Revit, try loading newer versions of these families: [Names]."
Public property Static member FamilyConnectorDeletedError The family Connector has been modified so the connection is invalid.
Public property Static member FamilyConnectorDeletedWarning The family Connector has been modified so the connection is invalid.
Public property Static member FamilyDoesntMatchSystemPropertiesDisconnected The family no longer matches the properties for the System. Disconnect the family from the System?
Public property Static member FamilyIsCorruptError Some families have become unusable. Reload the families, or delete them from the model.
Public property Static member FamilyIsCorruptWarning Some families have become unusable. Reload the families, or delete them from the model.
Public property Static member FamilyMembersReferToOutsideFamily Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.
Public property Static member FamilyNoExternalParametersError Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
Public property Static member FamilyNoExternalParametersWarning Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
Public property Static member FamilyNotFitHostShape The host shape has changed and the family is no longer appropriate.
Public property Static member FamilyOverconstraint Dimension overconstrains the Family. Cannot set Family Type to <None>.
Public property Static member FamilyOverconstraintCB Dimension overconstrains the Family.
Public property Static member FamilyParameterNoExist The parameter [Name] doesn't exist in the Family. It will be ignored.
Public property Static member FamilyValidationResult Family Validation Warning(s): [Description]
Public property Static member FormulaBasedParameterCannotBeChanged Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
Public property Static member FormulasFailedForType "Can't satisfy formulas for type [Family Symbol].
Public property Static member FrozenBecauseFaceGone This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
Public property Static member FrozenBecauseMonitorRelationshipGone The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
Public property Static member HighlightedElementFamRefsInvalidError One or more references of the highlighted element have become invalid.
Public property Static member HighlightedElementFamRefsInvalidWarning One or more references of the highlighted element have become invalid.
Public property Static member InsertOrientationChangedToBeValid The insert orientation was modified to be compatible with the wall's cross-section.
Public property Static member InstMayCutMoreOrFewerHosts Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
Public property Static member InstOutsideFaceBoundary Instance origin does not lie on host face. Instance will lose association to host.
Public property Static member InvalidContextForAdaptivePlacement The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
Public property Static member InvalidFamilyType Invalid family type "[Type Name]".
Public property Static member InvalidFormularFoundInParameter Invalid formular found in parameter '[Param Name]' in type '[Type Name]'.
Public property Static member InvalidInsertOrientation The insert orientation is incompatible with the wall's cross-section.
Public property Static member InvalidParameterValue Parameter [Caption] has an invalid value.
Public property Static member InvalidSlantedColumnOffsets The column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
Public property Static member InvalidSlantedColumnOffsetsInNestedFamily Instance of family [Family Name] can't be updated because in nested family the column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
Public property Static member MightntPlaceInsertsWarning There exist geometry collision. These elements might not be copied.
Public property Static member NoInstparamFormulas Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
Public property Static member NonGenericAnnotationsOutsideLegend Only Generic Annotations may be copied between Legends and other Views
Public property Static member NotFamilyFile The selected file is not a Family File.
Public property Static member ProfileContainsNoLoops Profile type '[Family Symbol]' contains no loops.
Public property Static member ReferencePlanesOverconstrained Reference Planes are overconstrained.
Public property Static member SetbackTooLarge Setback computations are too large for this element.
Public property Static member SharedParameterReplacedByBuiltInOne Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
Public property Static member SizeLookupTableIsNotAvailableForType Size Lookup Table is not available for type [Family Symbol].
Public property Static member SketchCannotBeAutomaticallyDimensioned Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
Public property Static member SlantedColumnEndCutPlaneIsParallelToGeometry Cut plane of slanted column end is parallel to the location curve.
Public property Static member SlantedColumnEndPlanesHaveFlipped Position of end cut planes has resulted in a slanted column without any geometry.
Public property Static member StructuralColumnAttachedToNonStructuralTarget The structural column is attached to a non-structural target.
Public property Static member TitleblockBadViewType Titleblocks can only be placed on sheets.
Public property Static member TryingToAttachWhenJoined The column and target are joined. The attachment has been removed.
Public property Static member TypeRecursiveElementIdParameter Type's parameter cannot recursively point to the type itself.
Public property Static member UnableGenerateTrussByFamilyAndOrientation Revit is unable to generate a truss using the current Layout Family and Truss orientation.
Public property Static member UnableToUpgradeDueToCorruptFamilies Some families have become unusable. Reload the families, or delete them from the model.
Public property Static member UnexpectedFamilyChangeResultsError Changing the family for a MEP fitting might cause unexpected results.
Public property Static member UnexpectedFamilyChangeResultsWarning Changing the family for a MEP fitting might cause unexpected results.
Public property Static member ValueOutOfRange The value must be from 0.0 to 1.0
Public property Static member WhileLoadingFamily While loading family '[Family Name]': [Description]
Public property Static member WhileLoadingFamilyShared While loading shared family '[Family Name]' from family '[Family Name]': [Description]
Public property Static member WhileScanningParametersForType While loading Type '[Name]', parameter '[Name]': [Description]
Top
See Also