View |
This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsViewFamilyTypeValidForCallout(
Document document,
ElementId viewFamilyTypeId,
ElementId parentViewId
)
Parameters
- document Document
- The document which contains the ViewFamilyType and parent view.
- viewFamilyTypeId ElementId
- The id of the ViewFamilyType which will be used by the new callout ViewSection. Detail ViewFamilyTypes can be used in all parent views except for CeilingPlan and Drafting views. FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail ViewFamilyTypes may be be used in parent views that also use a type with the same ViewFamily enum value. For example, in StructuralPlan views both StructuralPlan and Detail ViewFamilyTypes are allowed.
- parentViewId ElementId
- The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.
Return Value
BooleanTrue if the ViewFamilyType can be used for callout views in the parent view, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |