CreateHanger Method (Document, FabricationServiceButton, Int32, ElementId)


Fabrication Part Create Hanger(Document, Fabrication Service Button, Int 32, Element Id) Method

Creates a free placed hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FabricationPart CreateHanger(
	Document document,
	FabricationServiceButton button,
	int condition,
	ElementId levelId
)

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button to use.
condition Int32
The condition index. If the button has multiple conditions.
levelId ElementId
The level identifier associated with the level.

Return Value

FabricationPart
The newly-created fabrication hanger.
Exceptions
Exception Condition
ArgumentException Invalid fabrication service button.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The index condition is not larger or equal to 0 and less than ConditionCount.
See Also