GetOrCreateDefaultRebarShape Method


Path Reinforcement Get Or Create Default Rebar Shape Method

Creates a new RebarShape object with a default name or returns existing one which fulfills Path Reinforcement bending data requirements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId GetOrCreateDefaultRebarShape(
	Document document,
	ElementId rebarBarTypeId,
	ElementId startRebarHookTypeId,
	ElementId endRebarHookTypeId
)

Parameters

document Document
The document.
rebarBarTypeId ElementId
The id of the RebarBarType.
startRebarHookTypeId ElementId
The id of the RebarHookType for the start of the bar. If this parameter is InvalidElementId, it means to create a rebar with no start hook.
endRebarHookTypeId ElementId
The id of the RebarHookType for the end of the bar. If this parameter is InvalidElementId, it means to create a rebar with no end hook.

Return Value

ElementId
Rebar Shape id.
Exceptions
Exception Condition
ArgumentException rebarBarTypeId should refer to an RebarBarType element. -or- startRebarHookTypeId should be invalid or refer to an RebarHookType element. -or- endRebarHookTypeId should be invalid or refer to an RebarHookType element.
ArgumentNullException A non-optional argument was null
See Also