SetFilterOverrides Method


View Set Filter Overrides Method

Sets the overrides associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetFilterOverrides(
	ElementId filterElementId,
	OverrideGraphicSettings overrideGraphicSettings
)

Parameters

filterElementId ElementId
ElementId of the filter.
overrideGraphicSettings OverrideGraphicSettings
The overrides to apply to the filter.
Exceptions
Exception Condition
ArgumentException ElementId is not associated with a FilterElement. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
ArgumentNullException A non-optional argument was null
InvalidOperationException The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
If the filter is not currently applied to the view, this will add the filter with the assigned overrides.
See Also