DetachFromCentralOption Enumeration


Detach From Central Option Enumeration

Options for workset detachment behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum DetachFromCentralOption
Members
Member name Value Description
ClearTransmittedSaveAsNewCentral 3 After opening the transmitted, workshared model, immediately resave it with its current name and clear the transmitted flag.
DetachAndDiscardWorksets 2 Detach the model being opened from its central model and discard worksets/worksharing.
DetachAndPreserveWorksets 1 Detach the file being opened from its central file.
DoNotDetach 0 Do not detach the file being opened from its central file.
See Also