Family |
Set the ElementId value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- familyParameter FamilyParameter
- A family parameter of the current type.
- value ElementId
- The new value for family parameter.

Exception | Condition |
---|---|
ArgumentException | Thrown when the storage type of family parameter is not ElementId --or-- The input ElementId does not represent either a valid element in the document or InvalidElementId. |
ArgumentOutOfRangeException | Thrown when the input ElementId is not valid as a value for this FamilyParameter. |
InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid. |