Revit |
Sets phase filter id and phase filter type of RevitLinkGraphicsSettings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- phaseFilterType LinkVisibility
- The type of the phase filter.
- phaseFilterId ElementId
- The id of the phase filter from the linked document or InvalidElementId . If phaseFilterType is set to ByHostView or ByLinkView the phaseFilterId must be set to InvalidElementId . If phaseFilterType is set to Custom and phaseFilterId is InvalidElementId the state of the phase filter will correspond to the None option in the UI.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |