IsValidFormula Method


Global Parameter Is Valid Formula Method

Tests that the given expression is a valid as formula for this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidFormula(
	string expression
)

Parameters

expression String

Return Value

Boolean
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Use this method to test validity of a formula before assigning it to a global parameter when in doubt whether it is an acceptable expression or not.
See Also