EraseSchemaAndAllEntities Method


Document Erase Schema And All Entities Method

Erases Schema and all its Entities from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void EraseSchemaAndAllEntities(
	Schema schema
)

Parameters

schema Schema
The Schema to erase.
Exceptions
Exception Condition
ArgumentException No write access to this Schema.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
The Schema remains in memory.
See Also