GetListStartNumber Method


Formatted Text Get List Start Number Method

Returns the list start number of the paragraphs in a given text range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetListStartNumber(
	TextRange textRange
)

Parameters

textRange TextRange
The given text range.

Return Value

Int32
The list start number of the text range.
Exceptions
Exception Condition
ArgumentException This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
Remarks
Returns -1 if there is a mix of list start values in the range or if there are paragraphs in different lists or sub-lists in the range or if there are paragraphs of type None or Bullet in the range.
See Also