View Get |
Checks if elements of the given category are set to be invisible (hidden) in this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- categoryId ElementId
- The ID of the category.
Return Value
BooleanTrue if the category is invisible (hidden), false otherwise.

Exception | Condition |
---|---|
ArgumentException | categoryId does not correspond to a Category. |
ArgumentNullException | A non-optional argument was null |

This checks only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
- The category classes settings for model categories, annotation categories, import categories or analytical model categories.
- View filters.
- Elements hidden individually in the view.