DefinitionBindingMap Class


Definition Binding Map Class

A map that contains mappings of parameter definitions to parameter bindings.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DefinitionBindingMap : APIObject, 
	IEnumerable

The DefinitionBindingMap type exposes the following members.

Constructors
Name Description
Public method DefinitionBindingMap Initializes a new instance of the DefinitionBindingMap class
Top
Properties
Name Description
Public property IsEmpty Test to see if the map is empty.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Item
Public property Size Returns the number of bindings that are in the map.
Top
Methods
Name Description
Public method Clear Removes every binding from the map, rendering it empty.
Public method Contains
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Erase
Public method ForwardIterator Retrieve a forward moving iterator to the map.
Public method GetEnumerator Retrieve a forward moving iterator to the map.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Insert
Public method ReverseIterator Retrieve a backward moving iterator to the map.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also