IsDocumentUsingEnergyDataAnalyticalModel Method


Energy Data Settings Is Document Using Energy Data Analytical Model Method

Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsDocumentUsingEnergyDataAnalyticalModel(
	Document ccda
)

Parameters

ccda Document
The document.

Return Value

Boolean
Returns true if the Conceptual Energy Analytical Model is enabled, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also