RibbonPanel Class


Ribbon Panel Class

Represents a panel added by an External Application or External Command into the Add-Ins tab.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI RibbonPanel

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RibbonPanel

The RibbonPanel type exposes the following members.

Properties
Name Description
Public property Enabled Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
Public property Name Gets or sets the name of the RibbonPanel.
Public property Title Gets or sets the text of the RibbonPanel.
Public property Visible Gets or sets a value indicating whether the RibbonPanel is displayed.
Top
Methods
Name Description
Public method AddItem Adds a Ribbon item to the panel.
Public method AddSeparator Adds a new Separator to the panel.
Public method AddSlideOut Adds a slideout to the current panel.
Public method AddStackedItems(RibbonItemData, RibbonItemData) Adds two stacked items to the panel.
Public method AddStackedItems(RibbonItemData, RibbonItemData, RibbonItemData) Adds three stacked items to the panel.
Public method Equals Determines whether the specified Object is equal to the current Object .
(Overrides Object Equals(Object) )
Public method GetItems Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.
Top
Remarks
The Panel class provides read and write access to the RibbonItems contained in the panel. Use of this class is not supported in Revit Macros.
See Also