SetCropShape Method


View Crop Region Shape Manager Set Crop Shape Method

Sets the boundary of the view's crop to the specified shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCropShape(
	CurveLoop boundary
)

Parameters

boundary CurveLoop
The crop boundary.
Exceptions
Exception Condition
ArgumentException Boundary in boundary should represent one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
ArgumentNullException A non-optional argument was null
InvalidOperationException The crop of the associated view is not permitted to have a non-rectangular shape.
Remarks

Depending on the shape of the argument, view's crop is set to be either rectangular or non-rectangular. If the crop is set to be rectangular and it is also split, then the multiple view regions will be displayed for the view, with the same proportions as the split prior to the change, but adjusted to the new rectangular shape.

This Method is reserved for setting crop shape in views that allow non-rectangular crop shapes - see property CanHaveShape . For views that don't allow non-rectangular crop shapes (e.g. View3D ), please use property CropBox for that purpose.

See Also