ElectricalDemandFactorValue Class


Electrical Demand Factor Value Class

This class represents values used by a particular demand factor definition. Each instance corresponds to a row in a table of values. These values are part of the ElectricalDemandFactorDefinition class.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical ElectricalDemandFactorValue

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElectricalDemandFactorValue : IDisposable

The ElectricalDemandFactorValue type exposes the following members.

Constructors
Name Description
Public method ElectricalDemandFactorValue Default constructor. Initializes factor to 1.0 or 100%. Min and max range are set to 0.0
Public method ElectricalDemandFactorValue(Double, Double, Double) Constructor. Initializes factor, minimum range and maximum range to values passed in.
Top
Properties
Name Description
Public property Factor The demand factor for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the demand factor will be 1.0.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MaxRange The maximum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the maximum range will be 3.
Public property MinRange The minimum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the minimum range will be 1.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ElectricalDemandFactorValue
Public method SetMaxRangeToUnlimited Sets the max range on the value to unlimited
Top
See Also