Button |
Base class used to contain information necessary to construct a button in the Ribbon.

System Object
Autodesk.Revit.UI ItemData
Autodesk.Revit.UI RibbonItemData
Autodesk.Revit.UI ButtonData
Autodesk.Revit.UI PulldownButtonData
Autodesk.Revit.UI PushButtonData
Autodesk.Revit.UI ItemData
Autodesk.Revit.UI RibbonItemData
Autodesk.Revit.UI ButtonData
Autodesk.Revit.UI PulldownButtonData
Autodesk.Revit.UI PushButtonData
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The ButtonData type exposes the following members.

Name | Description | |
---|---|---|
![]() | Image | The image of the button. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ItemData ) |
![]() | LargeImage | The large image of the button. |
![]() | LongDescription | Long description of the command tooltip (Inherited from RibbonItemData ) |
![]() | Name | The internal name of the item. (Inherited from ItemData ) |
![]() | Text | The user-visible text of the button. |
![]() | ToolTip | The tooltip of item. (Inherited from ItemData ) |
![]() | ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItemData ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ItemData ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |