Button |
Base class used to contain information necessary to construct a button in the Ribbon.

System Object
Autodesk.Revit.UI ItemData
Autodesk.Revit.UI RibbonItemData
Autodesk.Revit.UI ButtonData
Autodesk.Revit.UI PulldownButtonData
Autodesk.Revit.UI PushButtonData
Autodesk.Revit.UI ItemData
Autodesk.Revit.UI RibbonItemData
Autodesk.Revit.UI ButtonData
Autodesk.Revit.UI PulldownButtonData
Autodesk.Revit.UI PushButtonData
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The ButtonData type exposes the following members.

Name | Description | |
---|---|---|
![]() | Image | The image of the button. |
![]() | LargeImage | The large image of the button. |
![]() | Text | The user-visible text of the button. |

Name | Description | |
---|---|---|