FabricationAncillaryUsage Class


Fabrication Ancillary Usage Class

Structure that holds information about the usage of a fabrication ancillary
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FabricationAncillaryUsage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationAncillaryUsage : IDisposable

The FabricationAncillaryUsage type exposes the following members.

Properties
Name Description
Public property AncillaryDepth Depth of required ancillary if it isn't round.
Public property AncillaryId Fabrication ancillary database identifier.
Public property AncillaryWidthOrDiameter Width or diameter of required ancillary.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Length Length of required ancillaries.
Public property ProductCode A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.
Public property Quantity Quantity of required ancillaries.
Public property Type Fabrication ancillary type.
Public property UsageType Fabrication ancillary usage type.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FabricationAncillaryUsage
Top
See Also